Upstream Provider Issues
Incident Report for BitCloud
Resolved
The reboot has been completed and all systems have returned to normal.
Posted Jun 21, 2023 - 15:24 PDT
Investigating
We identified an issue with one of our shared hosting systems that requires an emergency reboot. We will provide updates when the system is back online.
Posted Jun 21, 2023 - 15:01 PDT
This incident affected: BitCloud (Hosting 2).