Hosting My Account Style Issues
Incident Report for BitCloud
Resolved
The upgrade required by our third-party vendor has been completed. Self-serve account management and billing has been fully restored.
Posted Apr 11, 2023 - 13:45 PDT
Update
We continue to work on the repair of our account management system and are awaiting an update from our vendor responsible for this system. In the meantime, you can access your account to manage hosting functions by visiting https://yourwebsite.com/cpanel
Posted Jan 20, 2023 - 09:20 PST
Investigating
We're investigating an issue with our online portal for hosting account management. Clients may receive a 404 or unstylized pages.
Posted Jan 19, 2023 - 11:07 PST
This incident affected: BitCloud (Hosting 1, Hosting 2, BitCloud API Hosting Services) and Bit Corporate (BitNet).