Upstream Provider Issues
Incident Report for BitCloud
Resolved
Our upstream provider is experiencing issues. Customers may experience intermittent issues connecting to our services while our provider resolves the issue.

UPDATE: Our issues were resolved and we have returned to normal operation.
Posted Apr 21, 2023 - 02:30 PDT